SciLor's Open Source Forums
http://forum.scilor.com/

[API] GetArtistAutocomplete not working
http://forum.scilor.com/viewtopic.php?f=227&t=1718
Page 1 of 1

Author:  nawuko [ Wed Apr 04, 2012 11:24 pm ]
Post subject:  [API] GetArtistAutocomplete not working

Hello,

API -> GetArtistAutocomplete is currently not working, stack trace:

Code:
java.lang.Exception: Create Response Error: Unexpected response format ()
        at Base.GroovesharkRequestBuilder.CreateResponse(GroovesharkRequestBuilder.java:113)
        at Base.GroovesharkRequestBuilder.MakeRequest(GroovesharkRequestBuilder.java:177)
        at Base.GroovesharkClient.GetArtistAutocomplete(GroovesharkClient.java:547)
        at Downloader.ServerThread.autoComplete(ServerThread.java:129)
        at Downloader.ServerThread.run(ServerThread.java:238)
        at java.lang.Thread.run(Unknown Source)


I think grooveshark(tm) renamed/changed this function to "getAutocomplete" with the type "artist":

Request:
Code:
{"header":{"client":"htmlshark","clientRevision":"20120312","privacy":"1","country":"NORMALCOUNTRYFLAGS","uuid":"MYUID","session":"MYSESSION","token":"MYTOKEN"},"method":"getAutocomplete","parameters":{"query":"Coldplay","type":"artist"}}

Response:
Code:
{"header":{"session":"MYSESSION","serviceVersion":"20100903","prefetchEnabled":true},"result":[{"SongID":"30727029","AlbumID":"111776","ArtistID":"61","GenreID":"7","SongName":"Moses","AlbumName":"Live 2003","ArtistName":"Coldplay","Year":"2003","TrackNum":"8","CoverArtFilename":"111776.jpg","ArtistCoverArtFilename":"61.jpg","TSAdded":"1306569571","AvgRating":"0.000000","AvgDuration":"0.000000","EstimateDuration":"0.000000","Flags":0,"IsLowBitrateAvailable":"0","IsSponsored":"0","IsVerified":"0","AlbumVerified":1,"ArtistVerified":1,"Popularity":1208400124,"AlbumPopularity":1135700807,"ArtistPopularity":1135718067,"SongPlays":1256,"ArtistPlays":3062579,"QuerySongClicks":0,"SphinxWeight":7734,"Score":0,"Name":"Coldplay"}]}

--
Sorry for my bad english, it is not my primary language

Author:  SciLor [ Sat Apr 07, 2012 9:19 am ]
Post subject:  Re: [API] GetArtistAutocomplete not working

I have just fixed it in the API. With the next release it will be fine again.

Author:  nawuko [ Sat Apr 28, 2012 3:06 pm ]
Post subject:  Re: [API] GetArtistAutocomplete not working

No Update yet ?

Page 1 of 1 All times are UTC + 1 hour [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/