SciLor's Open Source Forums

Also visit my Website!
It is currently Sat Dec 14, 2019 1:03 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Jan 13, 2011 12:42 pm 
I'm using the Pre-Alpha3 version on a Ubuntu 10.10 machine, tried the example from the download page:

java -jar SciLorsJGroovesharkDownloader.jar /c /l "David Guetta"

and this is what I get:


SciLor's Java grooveshark(tm).com Downloader Pre-Alpha v3
Arguments:
"/c" "/l" "David Guetta"

gnu.xml.dom.ls.DomLSException
at gnu.xml.dom.ls.DomLSParser.doParse(libgcj.so.10)
at gnu.xml.dom.ls.DomLSParser.parse(libgcj.so.10)
at gnu.xml.dom.ls.DomLSParser.parseURI(libgcj.so.10)
at gnu.xml.dom.DomDocumentBuilder.parse(libgcj.so.10)
at Base.GrooveFix.<init>(GrooveFix.java:33)
at Base.GroovesharkClient.Connect(GroovesharkClient.java:76)
at Base.GroovesharkClient.CheckConnect(GroovesharkClient.java:68)
at Base.GroovesharkClient.SearchArtist(GroovesharkClient.java:238)
at Base.GroovesharkClient.SearchArtist(GroovesharkClient.java:233)
at test.JGroovesharkDownloader.listSearch(JGroovesharkDownloader.java:131)
at test.JGroovesharkDownloader.main(JGroovesharkDownloader.java:78)
Caused by: org.xml.sax.SAXParseException
at gnu.xml.stream.SAXParser.parse(libgcj.so.10)
at gnu.xml.dom.ls.DomLSParser.doParse(libgcj.so.10)
...10 more
Caused by: javax.xml.stream.XMLStreamException
at gnu.xml.stream.XMLParser.next(libgcj.so.10)
at gnu.xml.stream.SAXParser.parse(libgcj.so.10)
...11 more
Caused by: java.io.UnsupportedEncodingException: document is not in its declared encoding UTF-8: utf-8
at gnu.xml.stream.XMLParser$Input.setInputEncoding(libgcj.so.10)
at gnu.xml.stream.XMLParser.readXMLDecl(libgcj.so.10)
at gnu.xml.stream.XMLParser.next(libgcj.so.10)
...12 more
Error occured:
null


is this a bug, or something wrong in my Ubuntu installation, or something to set somewhere?
thanks
bye


Top
  
 
 
Online
The Adswinger

Joined: Wed Jan 13, 2010 11:56 pm
Posts: Too many!
Donated: Ad Posts


PostPosted: Thu Jan 13, 2011 6:16 pm 
Found the solution... my Ubuntu was using the wrong Java version..

java -version

gave me:

java version "1.5.0"
gij (GNU libgcj) version 4.4.5

so I installed Java JRE 6 with this command :

sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

then I selected it as the Java to use with this command :

update-alternatives --config java

the result was: Selection Path Priority Status
------------------------------------------------------------
* 0 /usr/bin/gij-4.4 1044 auto mode
1 /usr/bin/gij-4.4 1044 manual mode
2 /usr/lib/jvm/java-6-sun/jre/bin/java 63 manual mode

so I selected the option 2 and after that the downloader worked fine


Top
  
 
PostPosted: Thu Jan 13, 2011 9:49 pm 
Offline
The Developer

Joined: Wed Jan 13, 2010 11:56 pm
Posts: 1466
Donated: free software
fine that it works for you now :)

_________________
My Windows Mobile and Windows Open Source Website:
www.scilor.com

Like my work? Donate!
Donation Website

My Programs:
grooveshark™.com Downloader, GrooveMobile, Fuel Blaster, Chameleon TicTacToe, QuickTap, WiMoBlue, Driving Licence Trainer, CodeSnippetViewer, Gesture Launcher, Fahrplanauskunft, GSensor Control


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
template->_php_include(): File ./counter/foruminclude.php does not exist or is empty Powered by phpBB® Forum Software © phpBB Group